use strict;
my $str = 'produkt: Tričko, Rozměr 1x1x1cm, Material Aloe Vera 200g A_203
produkt: Tričko, Rozměr 2x3x2cm, Material Aloe 203
produkt: Tričko, Rozměr 2x3cm, Materiál Bavlna 400g N_W245_2017
';
my $regex = qr/(?<=Materi.l )\D+/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}