import re
regex = re.compile(r"(?<=Materi.l )\D+", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("produkt: Tričko, Rozměr 1x1x1cm, Material Aloe Vera 200g A_203\n"
"produkt: Tričko, Rozměr 2x3x2cm, Material Aloe 203\n"
"produkt: Tričko, Rozměr 2x3cm, Materiál Bavlna 400g N_W245_2017\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")