re = /(?<=Materi.l )\D+/mi
str = 'produkt: Tričko, Rozměr 1x1x1cm, Material Aloe Vera 200g A_203
produkt: Tričko, Rozměr 2x3x2cm, Material Aloe 203
produkt: Tričko, Rozměr 2x3cm, Materiál Bavlna 400g N_W245_2017
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end