import Foundation
let pattern = #"(?<=Materi.l )\D+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
produkt: Tričko, Rozměr 1x1x1cm, Material Aloe Vera 200g A_203
produkt: Tričko, Rozměr 2x3x2cm, Material Aloe 203
produkt: Tričko, Rozměr 2x3cm, Materiál Bavlna 400g N_W245_2017
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)