const regex = /\S+(?: \S+)*| {2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+(?: \\S+)*| {2,}', 'gm')
const str = `This line with sometimes more than 1 space needs to be captured in 3 matches with 2 groups.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}