$re = '/[^A-Za-z0-9]+/m';
$str = '_<$abc$>_';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;