import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*src\\/(([^\\/]*)(\\/)?)|(\\/)([^\\/]*)";
final String string = "/dev/project/src/MVC/Models/Access/Auth\n\n\n"
+ "/home/user/dev/project/src/MVC/Models/Access/Auth\n\n\n"
+ "/any_other_folder/src/MVC/Models/Access/Auth";
final String subst = "$2\\\\$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}