package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<foo>)(.*?)(<bar>)`)
var str = `This is some variable text
<foo> some stuff <Hello World> other stuff <bar>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}