$re = '/(<foo>)(.*?)(<bar>)/m';
$str = 'This is some variable text
<foo> some stuff <Hello World> other stuff <bar>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);