using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img(?!.*?alt=(['""]).*?\2)[^>]*)(>)";
string input = @"<html>
<body>
<img src=""tos.jpg"">
<img src=""hfgfg.jpg"" alt=""texter alternatif"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}