import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<img(?!.*?alt=(['\"]).*?\\2)[^>]*)(>)";
final String string = "<html>\n"
+ "<body>\n"
+ "<img src=\"tos.jpg\">\n\n"
+ "<img src=\"hfgfg.jpg\" alt=\"texter alternatif\">\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}