#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{0,72}$)(vim-patch.*|(fix|feat|docs|test|perf|refactor|chore|build)(\([^)]+\))?!?:\s[a-z].*[^.]$)"
Local $sString = "feat(api): this is great " & @CRLF & _
"vim-patch:supportsanything" & @CRLF & _
"fix!: breaking change support" & @CRLF & _
"feat: No uppercase at start" & @CRLF & _
"feat: not ending with dot." & @CRLF & _
"feat: too long of a commit message is not allowed over 71 characters long" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")