using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([a-z0-9-_]{0,})\.){0,1}([a-z0-9-_]{1,})\.[a-z]{2,}$";
string input = @"test@test.aaaa
domaine_invalide.test
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}