// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([a-z0-9-_]{0,})\.){0,1}([a-z0-9-_]{1,})\.[a-z]{2,}$").unwrap();
let string = "test@test.aaaa
domaine_invalide.test
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}