$re = '/^(?=.{6,}).*?\d.*?\d.*?$/m';
$str = '11aaaa
1aaa1a
z1zzz1a
11
z1zzz1assss
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);