const regex = /(?:[a-z0-9_-]+(?:\.[a-z0-9_-]+)*|"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|
\\[\x01-\x09\x0b\x0c\x0e-\x7f])*"){2,255}@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9]){1,255}?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9]){1,64}?|
\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:
(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[a-z0-9_-]+(?:\\.[a-z0-9_-]+)*|"(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21\\x23-\\x5b\\x5d-\\x7f]|
\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])*"){2,255}@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9]){1,255}?\\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9]){1,64}?|
\\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:
(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21-\\x5a\\x53-\\x7f]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])+)\\])', '')
const str = `valid.email@example.com
john.doe123@example.co.uk
alice_smith@company.org
user1234@emailprovider.net
test.email1234@email-domain.com
support@website.info
jane.doe@emailprovider.org
contact_us123@example.net
my.email123@email-provider.co
a@ce.ce
invalid.email@missingtld
john.doe@invaliddomain.c
spaces in@email.com
special!chars@email.com
noatemail.com
double..dots@email.com
@missingusername.com
user@inva@lid.com
missingatsigndomain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}