use strict;
my $str = 'https://stackoverflow.com/questions/ask
https://stackoverflow.co.uk/questions/ask
https://www.stackoverflow.com/questions/ask
http://www.stackoverflow.co.uk/questions/ask
http://www.stackoverflow.co.uk/
http://www.stackoverflow.co.uk';
my $regex = qr/(?i)^(?:https?:\/\/)(?:w{3}\.)?([^\r\n]+?)\.([a-z0-9]{2,6}(?:\.[a-z0-9]{2,6})?)\/?(.*)$/mp;
my $subst = '\\2/\\1/\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";