# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z]\d{4}$"
test_str = ("# The CMS, who maintain these codes, describe the format as:-\n"
"# \"HCPCS Level II codes (also known as alpha-numeric codes) consist of a single alphabetical letter followed by 4 numeric digits.\"\n"
"# (https://www.cms.gov/medicare/coding-billing/healthcare-common-procedure-system)\n"
"# NOTE: This regex will not identify HCPCS Level I codes (AKA CPT codes)\n"
"# Also, some sources say the single letter ranges only from A-V (this regex follows A-Z)\n"
"# Finally, this regex does not match procedure modifiers, which are 2 digit codes that follow a HCPCS code (with hyphen). \n"
"# (https://www.aapc.com/resources/what-are-medical-coding-modifiers)\n"
"# A separate regex has been created on regex101 supporting these modifiers\n\n"
"# Genuine codes\n"
"E8015\n"
"A6410\n"
"C5278\n"
"G2102\n"
"M1221\n"
"V2623\n"
"V2756\n"
"c5278\n"
"g2102\n"
"m1221\n"
"v2623\n"
"v2756\n"
"# Should fail\n"
"EE8015\n"
"6410\n"
"E641O\n"
"[6410\n"
"_6510\n"
"g212\n"
"C52789\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.