// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)^[a-zA-Z]\d{4}$").unwrap();
  let string = "# The CMS, who maintain these codes, describe the format as:-
# \"HCPCS Level II codes (also known as alpha-numeric codes) consist of a single alphabetical letter followed by 4 numeric digits.\"
# (https://www.cms.gov/medicare/coding-billing/healthcare-common-procedure-system)
# NOTE: This regex will not identify HCPCS Level I codes (AKA CPT codes)
# Also, some sources say the single letter ranges only from A-V (this regex follows A-Z)
# Finally, this regex does not match procedure modifiers, which are 2 digit codes that follow a HCPCS code (with hyphen).  
# (https://www.aapc.com/resources/what-are-medical-coding-modifiers)
# A separate regex has been created on regex101 supporting these modifiers
# Genuine codes
E8015
A6410
C5278
G2102
M1221
V2623
V2756
c5278
g2102
m1221
v2623
v2756
# Should fail
EE8015
6410
E641O
[6410
_6510
g212
C52789
";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}