$re = '/\b[a-z]{4,}s\b/m';
$str = 'hexes pixies major prairies caveman zipfiles oxes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);