use strict;
my $str = 'Some text #tag1 text #tag2 ...';
my $regex = qr/\S*#(\[[^\]]+\]|\S+)/mp;
my $subst = '<a href="targetpage.php?val=$1">#$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";