$re = '/^(?=.{12}$)[0-9a-zA-Z]*\s*$/m';
$str = 'abC123def456
abc123dEf45
abc123def4
sd45f45FFFRd
abc123def45
abc123 ef456
123
sd45f45FFFR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);