$re = '/^[^#\r\n]+(?= #)/m';
$str = 'These are words before hashtag #work/abc/xyz/123
hi #bye
#tuesday
hello world
more testing #aaa
one #two #three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);