#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)":(?:{(?:[^}[]+)?"name[s]?":\[?(?:"name":)?"|")([^"\\]+)"
Local $sString = ""author":"Lucy Bode","publisher":{"name":"Channel Void"" & @CRLF & _
""author":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"" & @CRLF & _
""author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""author":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""journalist":"Lucy Bode","publisher":{"name":"Channel Void"" & @CRLF & _
""journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""journalist":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""authors":"Lucy Bode","publisher":{"name":"Channel Void"" & @CRLF & _
""authors":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"" & @CRLF & _
""authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""authors":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"" & @CRLF & _
""person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""Person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"" & @CRLF & _
""Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""Person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"" & @CRLF & _
""author":{"@type":"Person","name":"Lucy Bode"}" & @CRLF & _
""image":{"@type":"ImageObject","url":"https://static.nationalgeographic.co.uk/files/styles/image_3200/public/rewilding-redonda.jpg?w=1900&h=1267","width":1900,"height":1267,"author":{"@type":"Person","name":"Ed Marshall, Redonda Restoration Programme"},"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")