using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)"":(?:{(?:[^}[]+)?""name[s]?"":\[?(?:""name"":)?""|"")([^""\\]+)";
string input = @"""author"":""Lucy Bode"",""publisher"":{""name"":""Channel Void""
""author"":{""name"":""Lucy Bode""},""publisher"":{""name"":""Channel Void""
""author"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""author"":{""names"":[""name"":""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""author"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""journalist"":""Lucy Bode"",""publisher"":{""name"":""Channel Void""
""journalist"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""journalist"":{""names"":[""name"":""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""journalist"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""authors"":""Lucy Bode"",""publisher"":{""name"":""Channel Void""
""authors"":{""name"":""Lucy Bode""},""publisher"":{""name"":""Channel Void""
""authors"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""authors"":{""names"":[""name"":""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""authors"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""person"":{""name"":""Lucy Bode""},""publisher"":{""name"":""Channel Void""
""person"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""person"":{""names"":[""name"":""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""person"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""Person"":{""name"":""Lucy Bode""},""publisher"":{""name"":""Channel Void""
""Person"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""Person"":{""names"":[""name"":""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""Person"":{""names"":[""Lucy Bode""]},""publisher"":{""name"":""Channel Void""
""author"":{""@type"":""Person"",""name"":""Lucy Bode""}
""image"":{""@type"":""ImageObject"",""url"":""https://static.nationalgeographic.co.uk/files/styles/image_3200/public/rewilding-redonda.jpg?w=1900&h=1267"",""width"":1900,""height"":1267,""author"":{""@type"":""Person"",""name"":""Ed Marshall, Redonda Restoration Programme""},";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}