package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)":(?:{(?:[^}[]+)?"name[s]?":\[?(?:"name":)?"|")([^"\\]+)`)
var str = `"author":"Lucy Bode","publisher":{"name":"Channel Void"
"author":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":"Lucy Bode","publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":"Lucy Bode","publisher":{"name":"Channel Void"
"authors":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"@type":"Person","name":"Lucy Bode"}
"image":{"@type":"ImageObject","url":"https://static.nationalgeographic.co.uk/files/styles/image_3200/public/rewilding-redonda.jpg?w=1900&h=1267","width":1900,"height":1267,"author":{"@type":"Person","name":"Ed Marshall, Redonda Restoration Programme"},`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}