import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)\":(?:\\{(?:[^\\}[]+)?\"name[s]?\":\\[?(?:\"name\":)?\"|\")([^\"\\\\]+)";
final String string = "\"author\":\"Lucy Bode\",\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"author\":{\"name\":\"Lucy Bode\"},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"author\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"author\":{\"names\":[\"name\":\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"author\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"journalist\":\"Lucy Bode\",\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"journalist\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"journalist\":{\"names\":[\"name\":\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"journalist\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"authors\":\"Lucy Bode\",\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"authors\":{\"name\":\"Lucy Bode\"},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"authors\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"authors\":{\"names\":[\"name\":\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"authors\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"person\":{\"name\":\"Lucy Bode\"},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"person\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"person\":{\"names\":[\"name\":\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"person\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"Person\":{\"name\":\"Lucy Bode\"},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"Person\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"Person\":{\"names\":[\"name\":\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"Person\":{\"names\":[\"Lucy Bode\"]},\"publisher\":{\"name\":\"Channel Void\"\n"
+ "\"author\":{\"@type\":\"Person\",\"name\":\"Lucy Bode\"}\n"
+ "\"image\":{\"@type\":\"ImageObject\",\"url\":\"https://static.nationalgeographic.co.uk/files/styles/image_3200/public/rewilding-redonda.jpg?w=1900&h=1267\",\"width\":1900,\"height\":1267,\"author\":{\"@type\":\"Person\",\"name\":\"Ed Marshall, Redonda Restoration Programme\"},";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}