const regex = /"(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)":(?:{(?:[^}[]+)?"name[s]?":\[?(?:"name":)?"|")([^"\\]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)":(?:{(?:[^}[]+)?"name[s]?":\\[?(?:"name":)?"|")([^"\\\\]+)', 'gm')
const str = `"author":"Lucy Bode","publisher":{"name":"Channel Void"
"author":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":"Lucy Bode","publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":"Lucy Bode","publisher":{"name":"Channel Void"
"authors":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"@type":"Person","name":"Lucy Bode"}
"image":{"@type":"ImageObject","url":"https://static.nationalgeographic.co.uk/files/styles/image_3200/public/rewilding-redonda.jpg?w=1900&h=1267","width":1900,"height":1267,"author":{"@type":"Person","name":"Ed Marshall, Redonda Restoration Programme"},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}