#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)iPhone|iPod|Android.*Chrome/[.0-9]* Mobile|Mobile.*Firefox"
Local $sString = "iPhone asd" & @CRLF & _
"iPod asd" & @CRLF & _
"Android merda Chrome/123 Mobile" & @CRLF & _
"Tonino Browser" & @CRLF & _
"Mobile asd Firefox/123" & @CRLF & _
"Firefox Desktop" & @CRLF & _
"Firefox/Desktop" & @CRLF & _
"Firefox/asd" & @CRLF & _
"Desktop Firefox/123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")