import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "iPhone|iPod|Android.*Chrome/[.0-9]* Mobile|Mobile.*Firefox";
final String string = "iPhone asd\n"
+ "iPod asd\n"
+ "Android merda Chrome/123 Mobile\n"
+ "Tonino Browser\n"
+ "Mobile asd Firefox/123\n"
+ "Firefox Desktop\n"
+ "Firefox/Desktop\n"
+ "Firefox/asd\n"
+ "Desktop Firefox/123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}