const regex = new RegExp('iPhone|iPod|Android.*Chrome/[.0-9]* Mobile|Mobile.*Firefox', 'gm')
const str = `iPhone asd
iPod asd
Android merda Chrome/123 Mobile
Tonino Browser
Mobile asd Firefox/123
Firefox Desktop
Firefox/Desktop
Firefox/asd
Desktop Firefox/123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}