$re = '@iPhone|iPod|Android.*Chrome/[.0-9]* Mobile|Mobile.*Firefox@m';
$str = 'iPhone asd
iPod asd
Android merda Chrome/123 Mobile
Tonino Browser
Mobile asd Firefox/123
Firefox Desktop
Firefox/Desktop
Firefox/asd
Desktop Firefox/123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);