$re = '/^stats\.gauges\.all\.cloudwatch\.communicationapi\.dynamodb\.(\w{2})_communicationapi_restaurantdispatchmethods\.(\w+)readcapacityunits\.maximum$/m';
$str = 'stats.gauges.all.cloudwatch.communicationapi.dynamodb.ca_communicationapi_restaurantdispatchmethods.provisionedreadcapacityunits.maximum
stats.gauges.all.cloudwatch.communicationapi.dynamodb.es_communicationapi_restaurantdispatchmethods.consumedreadcapacityunits.maximum
stats.gauges.all.cloudwatch.communicationapi.dynamodb.ca_communicationapi_restaurantdispatchmethods.provisionedreadcapacityunits.maximum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);