re = /^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@][a-z][a-z0-9]{2,9}[.][a-z]{1,3}/m
str = 'bhargavi.bommidi@gmail.com
lovely.bhar@rasna
rasna_bha@phb.in
^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@]^[a-z][a-z0-9]{2,9}[.]^[a-z]{1,3}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end