$re = '/\ba/';
$str = 'after // MATCH!
arrive // MATCH!
block // NO MATCH!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);