using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:C(?(3)(?(2)(?(1)(?!)|())|())|())|T(?(5)(?(4)(?!)|())|())){5}";
string input = @"TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TCCCC
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}