$re = '/(?:C(?(3)(?(2)(?(1)(?!)|())|())|())|T(?(5)(?(4)(?!)|())|())){5}/m';
$str = 'TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TCCCC
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);