#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "public \w*\s*class (.+)\.(\w+) \{\n([^\}]*)\}$"
Local $sString = "Compiled from "Test.kt"" & @CRLF & _
"public final class com.github.animeshz.keyboard.jni.Test {" & @CRLF & _
" public final native void test(kotlinx.coroutines.flow.Flow<java.lang.Integer>);" & @CRLF & _
" public com.github.animeshz.keyboard.jni.Test();" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")