# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?(DEFINE)
(?<tagName>
[a-z][a-z\d]*+ (?=[>\s\/])
)
(?<tagAttr>
(?>
[^>"']++
| " [^"]*+ "
| ' [^']*+ '
)*+
)
)
< (li|\/ul) \/?+ (?=[>\s\/]) ((?&tagAttr)) >
((?:
[^<]++
| < \/?+ (?!(?:li|ul)(?=[>\s\/])) (?&tagName) (?&tagAttr) > #any tag except <li> and <ul>
| < (?! \/?+ (?&tagName) ) #not tag
)*)
(?= < (?:li|\/ul) (?=[>\s\/]) (?&tagAttr) ) #check for nested <li> and <ul>/<$3$4>$5<\/LI>\r/gsixuX;t' <<< "<ul>
<li fhgfhfg ghgfhfghhfgh= ghghg=\"...\" a = 'ghghg'>dfdsfsd
<ul>
<li>111</li>
<li/>2222
<li>mmmmm</li>
</ul>
<li>dfdsfdsfsdf <b class=\"...\"><br/>fgdfgd<i></b><!-- dfdf--><li>
<li>
<li>dsfsdfsdfdsf
</ul>
"