using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(pinterest)";
string substitution = @"";
string input = @"pinterest.fr
pinterest.com
pinterest.com.mx";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}