use strict;
my $str = 'pinterest.fr
pinterest.com
pinterest.com.mx';
my $regex = qr/(pinterest)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";