import Foundation
let pattern = #"\<li\>[^<]*?(Fandoms).*?\<\/li\>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<p>by <a rel="author" href="/users/Ellixerff/pseuds/Ellixerff">Ellixerff</a></p>
<p>It's happened before, but this time is different. Can the consequences of bringing the one you love back, cost you ev fin story.</p>
<p>Words: 8003, Chapters: 7/7, Language: English</p>
<ul>
<li>Fandoms: <a full_pat class="tag" href="https://archiveofourown.org/tags/Xena:%20Warrior%20Princess/works">Xeni Princess</a></li>
<li>Rating: <a full_path="true" class="tag" href="https://archiveofourown.org/tags/Mature/works">Mature</a></li>
<li>Warnings: <a full_f class="tag" href="https://archiveofourown.org/tags/Choose"> Chose Not To Use Archive Warnings</a></li>
<li>Categories: <a full_path="true" class="tag" href="https://archiveofourown.org/tags/F*s*F/works">F/F</a></li>
<li>Characters: <a full_path="true" href="https://archiveofourown.org/tags/Gabrielle%20(Xena)/works">Gabrielle (Xena)</a></li>
<li><a fi class="tag" href="https://archiveofourown.org/tags/Xena%20(Xena)/works">Xena (Xena)</a></li>
<li>Relationships: <a full_path="true" class="tag" href="https://archiveofourown.org/tags/Gabrielle*s*Xena/works">Gabrielle/Xena</a></li>
</ul>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)