$re = '/(sst=[^&]+&)|((\?|&|^)sst=[^&]+$)/m';
$str = 'eg.com
eg.com?sst=12
eg.com?sst=12&from=nothing
eg.com?from=nothing&sst=12
eg.com?from=nothing&sst=12&to=nowhere
sst=12
sst=12&from=nothing
from=nothing&sst=12';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;