$re = '/^\d{2}(?:(?:\.\d{2}){3}|\d{6})$/m';
$str = '12.45.7810
12345678
12.34.56.78
1.234.56.78
12.45.7816 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);