$re = '/^.*?\(.*?\).*$/m';
$str = 'A 123
B 456
Ab(123)
uV(a5afgsg3)
A 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);