re = /\b(?:DE[0-9 ]{12}|DE ?[0-9]{9})(?!\d)/m
str = 'I want to get this DE813992525 and this DE813992526 number and this number DE 813 992 526 and this number DE 813992526. I do not want the banc account number: IBAN DE06300501100011054517.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end