// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\s+-[^-]*").unwrap();
let string = "\"Option 01 - Random phrase - Top Menu
\"Option 02 - Another Random Phrase - Su Menu
\"Option 03 - More 01 Phrase - Menu
\"Option 04 - More Phrase -
\"Option 05 - Simple Phrase";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}