re = /^(?=[^${}\r\n]*[${}])(?=[^\w\r\n]*\w)[\w${}]+$/m
str = 'rb_done_1
rb_${4}done'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end