const regex = /(?<=(?:1|^)(?!0{6})0{0,4})0/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:1|^)(?!0{6})0{0,4})0', 'gm')
const str = `11110000111100000000111100001111000000
1111....1111000000001111....1111000000`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);