re = /^\d{6}(18|19|20)\d{2}(0\d|10|11|12)([0-2]\d|30|31)\d{3}[\dXx]$/
str = '0341-86091234'
# Print the match result
str.match(re) do |match|
puts match.to_s
end